Low-PIM Products Overview

Low-PIM Products Overview

Amphenol Connex

This tutorial will provide an introduction to Passive Intermodulation. There will be an overview of products suited for Low-PIM applications.
View Training Module
Related Parts
Manufacturer Part NumberDescriptionPackagingAdapter TypeAdapter SeriesAvailable QuantityBuy Now
242282CONN ADAPT N JACK - 4.1/9.5 PLUGBulkPlug to JackN to 4.1/9.529 - Immediate
242136CONN ADAPT 7/16 PLUG TO N JACKBulkPlug to JackN to 7/1642 - Immediate
172372CONN ADAPT PLUG TO JACK N 50 OHMBulkPlug to JackN to N12 - Immediate
172369CONN ADAPT PLUG-PLUG N 50 OHMBulkPlug to PlugN to N9 - Immediate
242135CONN ADAPT N PLUG TO 7/16 JACKBulkPlug to JackN to 7/1610 - Immediate
242137CONN ADAPT N JACK TO 7/16 JACKBulkJack to JackN to 7/168 - Immediate
172371CONN ADAPT JACK-JACK N 50 OHMBulkJack to JackN to N14 - Immediate
272292CONN ADAPT JACK TO PLUG 7/16BulkPlug to Jack7/16 to 7/1612 - Immediate
242266CONN ADAPT 7/16 JACK TO SMA PLUGBulkPlug to JackSMA to 7/1611 - Immediate
172370CONN ADAPT JACK-JACK N 50 OHMBulkJack to JackN to N4 - Immediate
272300CONN ADAPT JACK-JACK 7/16 50 OHMBulkJack to Jack7/16 to 7/1611 - Immediate
242281CONN ADAPT 4.1/9.5 JACK - N PLUGBulkPlug to JackN to 4.1/9.519 - Immediate
242279CONN ADAPT PLUG-PLG 7/16-4.1/9.5BulkPlug to Plug7/16 to 4.1/9.518 - Immediate
242280CONN ADAPT 4.1/9.5 JACK - N JACKBulkJack to JackN to 4.1/9.518 - Immediate
242283CONN ADAPT N PLUG - 4.1/9.5 PLUGBulkPlug to PlugN to 4.1/9.517 - Immediate
332109CONN ADAPT JACK-JACK 4.1/9.5-Jack to Jack4.1/9.5 to 4.1/9.531 - Immediate
242276CONN ADAPT JACK-JCK 7/16-4.1/9.5BulkJack to Jack7/16 to 4.1/9.522 - Immediate
242277CONN ADAPT PLUG-JCK 7/16-4.1/9.5BulkPlug to Jack7/16 to 4.1/9.520 - Immediate
242278CONN ADAPT JACK-PLG 7/16-4.1/9.5BulkPlug to Jack7/16 to 4.1/9.520 - Immediate
272301CONN ADAPT JACK-JACK 7/16 50 OHMBulkJack to Jack7/16 to 7/164 - Immediate
242138CONN ADAPT N PLUG TO 7/16 PLUGBulkPlug to PlugN to 7/160
272134CONN ADAPT PLUG-PLUG 7/16 50 OHMBulkPlug to Plug7/16 to 7/160
To view modules, you will need Adobe Flash Player 9, or greater, installed on your computer. Adobe Flash Player is available FREE from Adobe.

Flash Player
Flash Player Support Center
PTM Published on: 2014-05-13